Forguncy サポート

[V6] 異なるバージョンのForguncy Serverにアプリケーションを配置できますか?

フォローする

対象製品とバージョン:Forguncy Server 6.0.5.0以降にForgucy 4以前のアプリを配置する

Forguncyでは、Forguncy BuilderとForguncy Serverのバージョンは、同じものを使用することを推奨しています。

基本的にメジャーバージョンが異なるForguncy BuilderからForguncy Serverに発行することはできません。
メジャーバージョンが同じで、マイナーバージョンがForguncy  BuilderよりForguncy Serverが高い場合には発行できます。
※メジャーバージョンとは、バージョン番号の先頭の数字。「6.0.5.0」の場合、メジャーバージョンは「6」。
※マイナーバージョンとは、バージョン番号の左から2番目以降の数字。「6.0.5.0」の場合、マイナーバージョンは「0.5.0」。

以下、例を元に対応状況を説明します。

組合わせのパターン Forguncy Builder Forguncy Server 対応状況
メジャーバージョンが同じ
6.0.5.0

6.0.5.0
◎推奨
メジャーバージョンが異なる(v4とv6の場合
4.0.108.0

6.0.5.0
Forguncy 4 BuilderからForguncy 6 Serverに発行はできない。
ただし、Forguncy 4 Serverで稼働しているアプリがあり、かつForguncy Serverをv4からv6にアップグレードした場合は、Forguncy 4 Serverで稼働していたアプリは、Forguncy 6 Serverアップデート後も動作する。(ユーザーアカウントなど必要な情報がForguncy 6 Serverで登録されていることが前提)
このように動作はするが、Forguncy 6 BuilderでForguncy 6 Serverに発行しなおすことを推奨。
メジャーバージョンが異なる(v3とv6の場合
3.0.116.0

6.0.5.0
Forguncy 3 BuilderからForguncy 6 Serverに発行はできない。
Forguncy 3 Builderで作成したアプリはForguncy 6 Serverで動作しない。
下記のリンク先に従ってアップグレード必須。

バージョンが異なる場合のアップグレード方法は、以下を参照してください。
Forguncyのアップグレード  

アプリケーションの配置方法は、Forguncy Builderから発行する方法と、パッケージファイルを作成して配置する方法があります。詳細は以下を参照してください。
アプリケーションの発行
オフラインでのアプリの配置

 

 

検索キーワード: fgcserver fgcoperation fgcdeploy

この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています
他にご質問がございましたら、リクエストを送信してください

コメント