Forguncy サポート

[V4] プラグイン開発に必要な環境

フォローする

対象製品とバージョン:Forguncy  4

 ※Forguncy 4のプラグイン開発キットに関する情報です。Forguncy 6以降のプラグイン開発については、各バージョンのオンラインヘルプの「プラグイン開発」をご確認ください。

 

プラグイン開発を行うために必要な環境は以下の通りです。

  1. プラグイン開発キット
    プラグイン開発キットの入手方法はこちらを参照してください。
  2. ビルドターゲットが.NET 4.6以上のプロジェクト開発に対応したVisual Studio
    例)Visual Studio 2017、Visual Studio 2015
  3. Forguncy Builder Pro
    バージョン4 以上のForguncy Builder Pro 製品版

 

※Visual StuidioとForguncy Builder Proは同一の環境にインストールされている必要があります。
プラグイン開発キットでは、Forguncy Builder Proに含まれるDLLを利用し、プラグインのテンプレートではビルド時にForguncy Builderへ自動的にインストールする機能を提供しています。そのため、プラグインのビルドと動作確認の両方にForguncy Builder Proを利用します。

 

検索キーワード: fgcplugindev

この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています
他にご質問がございましたら、リクエストを送信してください

コメント