Forguncy サポート

異なるバージョンのForguncy Serverにアプリケーションを配置できますか?

フォローする

対象製品とバージョン:Forguncy 3以降

 

アプリケーションを作成する際は、お使いのForguncy BuilderとForguncy Serverのバージョンを合わせておくことをお勧めしします。

 

ただし、Forguncy Builder(以下「Builder」と略します)とForguncy Server(以下「Server」と略します)のバージョンが異なる場合でも、以下のような条件下ではアプリケーションをServerに配置できます。

 

BuilderとServerのメジャーバージョンが同じで、Serverのマイナーバージョンが同じか高い場合。

 

たとえば、

Builderが「3.0.5.0」、Serverが「3.0.8.0」の場合はアプリケーションを配置できます。

Builderが「3.0.8.0」、Serverが「3.0.5.0」の場合はアプリケーションを配置できません。

Builderが「2.0.0.0」、Serverが「3.0.5.0」の場合はアプリケーションを配置できません。

Builderが「3.0.5.0」、Serverが「2.2.4.0」の場合はアプリケーションを配置できません。

 

メジャーバージョンとは、バージョン番号の左から1番目の数字を言います。 バージョンが「3.0.5.0」の場合は、「3」を指します。

マイナーバージョンとは、バージョン番号の左から2番目以降の数字を言います。 バージョンが「3.0.5.0」の場合は、「0.5.0」を指します。

 

アプリケーションの配置は、BuilderからServerに発行する方法と、パッケージファイルを作成してServer単体でアプリケーションを配置する方法があります。詳しくは、以下を参照してください。

 

アプリケーションを発行する

Forguncyサーバーマネージャーでアプリを配置する

 

検索キーワード: fgcserver fgcoperation fgcdeploy

他にご質問がございましたら、リクエストを送信してください

コメント