ファイルをダウンロードしようとすると、以下の警告が表示されダウンロードできない現象が発生します。
- Microsoft Edge:「安全にダウンロードすることはできません」
- Google Chrome:「安全でないダウンロードがブロックされました」
原因
Microsoft Edge(バージョン124以降)/Google Chromeでセキュリティ強化が行われ、HTTP通信で行われたダウンロードがブロックされるようになりました。
この警告は、ブラウザの想定通りの動きとなります。
対策
以前のように警告を出さないようにするには、以下のいずれかを検討してください。
- HTTPS通信のアプリケーションに変更します
アプリケーションをHTTPS通信にするには、あらかじめサーバー管理ポータルでSSLサーバー証明書を登録しておく必要があります。かつ、アプリケーションの発行時に「HHTPS」をチェックして発行する必要があります。
- HTTP通信のアプリケーションならばブラウザ の設定を変更し、安全でないコンテンツのアクセス許可を指定します
設定方法の詳細は、以下を参照してください。
Microsoft Edgeの場合
1.Edgeの画面右上の「…」から「設定」をクリックし、「Cookieとサイトのアクセス許可」を選択して「セキュリティで保護されていないコンテンツ」をクリックします。
2.「許可」の「追加」ボタンをクリックして、「サイトの追加」画面でForguncyアプリケーションのURLを入力してから「追加」ボタンをクリックします。
3.左ペインで「プライバシー、検索、サービス」をクリックし、「ブラウザーを閉じるたびにクリアするデータを選択する」をクリックします。「サイトのアクセス許可」のスイッチがオンの場合オフにしておくことで、Edgeを終了しても上記で追加したサイトの情報が維持されます。
Google Chromeの場合
1.Chromeの画面右上の「…」から「設定」をクリックし、「プライバシーとセキュリティ」を選択して「サイトの設定」をクリックします。
2.「その他コンテンツの設定」の下矢印をクリックます。
3.「安全でないコンテンツをクリック」します。
4.「安全でないコンテンツの表示を許可するサイト」の「追加」ボタンをクリックして、「サイトの追加」画面でForguncyアプリケーションのURLを入力してから「追加」ボタンをクリックします。
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